Site Search

Site Info

Home » Forums » Forum Archives » Networking and Internet Sharing » Topic # 390

Linksys LNE100TX problem
jj11 Nov-15-00 05:04 PM
I have read a few posts where users test a Linksys LNE100TX NIC and they get a address of FFFFFFFFFFFF. I recently bought one of their network in a box kits w/ those cards and I noticed the same thing.

First off, here is the system I am trying to install the card in.
FIC VA503+ motherboard w/ VIA chipset
AMD K6-2 350MHz CPU
128 MB RAM
Windows 98se

Here are my observations. If I run Linksys' diagnostic program (runs in DOS) just after physically installing the card but before Windows has detected and installed the drivers, I get a valid MAC address. However, after Windows has installed the drivers, the MAC address becomes FFFFFFFFFFFF. This happens every time I physically take the card out and replace it. I have tried it on both cards with the same result.

Also, the network does work using Netbios or TCPIP. However, I need to be able to use IPX for some of my games. Whenever I run Net Diag in Windows, I get "Unable to open IPX socket".

I do not know if one problem is related to the other or if they are 2 different issues. Any advice would be appreciated.


1. RE: Linksys LNE100TX problem
lbyard Nov-15-00 06:34 PM
In response to message 0
Do you have the VIA 4-in-1 drivers installed? In particular, I have seen network adapter conflicts when the IRQ miniport driver has not been installed. It could be that Windows cannot see the MAC address because of a confict (IRQ or port). Larry

2. RE: Linksys LNE100TX problem
jj11 Nov-15-00 07:07 PM
In response to message 1
Yes. When it didn't work, I went and downloaded the latest 4-in-1 drivers and installed them. However, I have disabled IRQ steering (I saw this suggestion in another forum). Should I restart IRQ steering? What are your suggestions for IRQ steering? I know that there are those 4 options for which routing tables are used. Which ones do you suggest I use? I've also tried the card in different PCI slots with no luck.

Also, is there a way I can completely uninstall and install the network stuff without doing a Windows install?

Thanks for any advice you can give.

3. RE: Linksys LNE100TX problem
lbyard Nov-15-00 08:22 PM
In response to message 2
I try hard not to do clean installs to solve problems and use it only as a last resort. Usually, one can simply delete all of the networking stuff in the Control Panel, Network, reboot, and reinstall. I have had to do it many times and it will often fix an otherwise unexplainable problem. The procedure (http://duxcw.com/dcforum/DCForumID2/327.html) can be much more complicated if there is a winsock problem.

I have often had to resort to IRQ steering/sharing for loaded computers. There are just not enough IRQs (http://duxcw.com/faq/irq/irq.htm) to go around in many computers. And I normally just set OS is PnP aware in the CMOS Setup and let Windows do its thing. But first, I would see if it is an IRQ problem by pulling everything out of the computer except the display adapter and network board and free-up all IRQs assigned to motherboard resources which are not needed; e.g., COM ports.
The following Microsoft Knowledge Base articles provide more info:




4. RE: Linksys LNE100TX problem
jj11 Nov-17-00 01:20 PM
In response to message 3
It looks like it was a winsock problem. I did the uninstall/reinstall procedure and reinstalled the card. I didn't have time to really test everything, but I did run Net Diag and did not get "Unable to open IPX socket" so I think that I am up and running.

I would just like to thank you for the great advice. I was almost at my wits end trying to figure this out.

Thanks a bunch.

| Home | Guides | How to | Reviews | Online Store | FAQ | Forums | Forum Archives |
| Links | News | Newsletter | About Dux | Advertising | Contact Info | Privacy |